Quantcast
nitrous woes - Beyond.ca - Car Forums
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 25

Thread: nitrous woes

  1. #1
    Join Date
    May 2002
    Location
    Victoria, BC
    Posts
    1,398
    Rep Power
    19

    Default nitrous woes

    that was my first, and most likely, last run with nitrous oxide




    $50.29 tow later...


    "Now me and the mad scientist gotta rip apart the block!"

  2. #2
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    '08 Mitsubishi Lancer, '97 GMC Jimmy
    Posts
    1,629
    Rep Power
    19

    Default

    LOL, ouch, shitty deal, sounds like you had fun though!
    "Car Manufacturers give us a well engineered basic car but leave it's real development to us."

  3. #3
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    6.7 CUMMINS
    Posts
    4,710
    Rep Power
    22

    Default

    shitty

  4. #4
    Join Date
    May 2002
    Location
    Victoria, BC
    Posts
    1,398
    Rep Power
    19

    Default

    yeah it was friggin fun!

    i think one of two things happened:


    the timing jumped, a LOT

    or it ran too lean and a valve(s) went bye-bye


    i shouldn't say it'll be my last run... heh

  5. #5
    Join Date
    Aug 2002
    Location
    Calgary
    My Ride
    MDX
    Posts
    2,139
    Rep Power
    19

    Default

    oh no!!!!! WTF did you do???

    Hey bol go to performance-shop.com and get a hold of calgaryss. He's running a damn quick s series with a 80shot! I'm sure he can help you out with your tuning issues.

  6. #6
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    6.7 CUMMINS
    Posts
    4,710
    Rep Power
    22

    Default

    Originally posted by legendboy
    shitty

  7. #7
    Join Date
    May 2002
    Location
    Victoria, BC
    Posts
    1,398
    Rep Power
    19

    Default

    Originally posted by legendboy


    k well since you, and most other people, probably want to know...


    I finished installing it, made a couple of runs, was hella impressed, went for another run, shifted into third gear, a second or two later, revs start goin up and down, truck slows down, engine dies.

    It'll turn over... but it's really really rough.

  8. #8
    Join Date
    Nov 2002
    Location
    Calgary
    My Ride
    2018 Ford F150, K6 GSXR 1000
    Posts
    1,116
    Rep Power
    18

    Default

    Originally posted by jdmakkord
    oh no!!!!! WTF did you do???

    Hey bol go to performance-shop.com and get a hold of calgaryss. He's running a damn quick s series with a 80shot! I'm sure he can help you out with your tuning issues.
    pretty sure he is running a 90 shot.

    here is his page.
    http://www.cardomain.com/member_page...page_id=219192

  9. #9
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    4cyl turbo diesel with a max speed of 10.9kmh
    Posts
    1,584
    Rep Power
    19

    Default

    ahahah dude, wtf are u thinking ?


    CONCRETE PATIO SPECIAL, PM ME FOR DETAILS!

  10. #10
    Join Date
    Nov 2002
    Location
    Medicine Hat
    My Ride
    2004 Toyota 4Runner V8 Sport
    Posts
    136
    Rep Power
    0

    Default

    Sounds, like it's not properly tuned.

    Did you check the plugs after each run to see if you had detonation.

    What type of kit do you have?

    I've had no problems with mine and I gone through 5 or 6 bottles so far!!!!
    2004 Toyota 4 Runner V8 Sport
    2001 Prelude SE- Sold
    Speed Kills...Drive a Ford...Live Forever!!!

  11. #11
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    4cyl turbo diesel with a max speed of 10.9kmh
    Posts
    1,584
    Rep Power
    19

    Default

    Originally posted by CanadaCivicSIR
    Sounds, like it's not properly tuned.

    Did you check the plugs after each run to see if you had detonation.

    What type of kit do you have?

    I've had no problems with mine and I gone through 5 or 6 bottles so far!!!!
    guy, you have nitrous in a prelude right? do u have any idea what this was in


    CONCRETE PATIO SPECIAL, PM ME FOR DETAILS!

  12. #12
    Join Date
    Nov 2002
    Location
    Medicine Hat
    My Ride
    2004 Toyota 4Runner V8 Sport
    Posts
    136
    Rep Power
    0

    Default

    An S-10!!!

    I have friends that have run nitrous on a S-10, you just have to use a small shot!
    2004 Toyota 4 Runner V8 Sport
    2001 Prelude SE- Sold
    Speed Kills...Drive a Ford...Live Forever!!!

  13. #13
    Join Date
    Jan 2003
    Location
    San Jose, CA, South of Canadia
    My Ride
    Baltic Green 2001 Jetta 2.sl0w
    Posts
    9
    Rep Power
    0

    Default

    you shouldn't have used two big ones.

    you got a heavy foot :-)

    350 cid time.

    2001.5 VW Jetta/Bora 2.sl0w (16" BBS Montreal II, Hella Micro DE foglights, Clarion HU, H&R/Bilstein sport coming soon)
    Sold: 1991 Suzuki GS500E (R1 clipons, adjustable front suspension)
    May be: CBR600F3 this summer?

  14. #14
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    4cyl turbo diesel with a max speed of 10.9kmh
    Posts
    1,584
    Rep Power
    19

    Default

    Originally posted by CanadaCivicSIR
    An S-10!!!

    I have friends that have run nitrous on a S-10, you just have to use a small shot!
    damn,that gives me an idea, what year s-10


    CONCRETE PATIO SPECIAL, PM ME FOR DETAILS!

  15. #15
    Join Date
    May 2002
    Location
    Victoria, BC
    Posts
    1,398
    Rep Power
    19

    Default

    Originally posted by CanadaCivicSIR
    Sounds, like it's not properly tuned.

    Did you check the plugs after each run to see if you had detonation.

    What type of kit do you have?

    I've had no problems with mine and I gone through 5 or 6 bottles so far!!!!

    i think it ran too lean but i'll know tomorrow when i rip open the engine, i'll check the plugs then too, but i'm pretty sure it's a valve busted

  16. #16
    Join Date
    Nov 2002
    Location
    Medicine Hat
    My Ride
    2004 Toyota 4Runner V8 Sport
    Posts
    136
    Rep Power
    0

    Default

    Hopefully you didn't do to much damage.

    You have to be careful, when running nitrous, mainly at the start, to make sure it's working right. After the intial trials, it becomes fun!!
    2004 Toyota 4 Runner V8 Sport
    2001 Prelude SE- Sold
    Speed Kills...Drive a Ford...Live Forever!!!

  17. #17
    Join Date
    May 2002
    Location
    Victoria, BC
    Posts
    1,398
    Rep Power
    19

    Default

    yeah i think my fuel pump didn't have enough get-up-and-go to supply the amount of fuel I needed

    or at least that's rages theory

  18. #18
    Join Date
    Nov 2002
    Location
    Medicine Hat
    My Ride
    2004 Toyota 4Runner V8 Sport
    Posts
    136
    Rep Power
    0

    Default

    Yes that could be.
    2004 Toyota 4 Runner V8 Sport
    2001 Prelude SE- Sold
    Speed Kills...Drive a Ford...Live Forever!!!

  19. #19
    Join Date
    May 2002
    Location
    Victoria, BC
    Posts
    1,398
    Rep Power
    19

    Default

    I think i'll go with a wet system next time though

  20. #20
    Join Date
    May 2002
    Location
    Vancouver
    Posts
    1,285
    Rep Power
    18

    Default

    was this in a 2.2?????? Sounds like a good excuse for a 383 swap

    LOL, "amatuers don't use nitrous oxide"

    How you think that kit would hold up in my 3L pushrod?
    "Its because they're stupid, that's why. That's why everyone does everything."

Page 1 of 2 1 2 LastLast

Similar Threads

  1. DivX woes

    By mrmattyk in forum General
    Replies: 7
    Latest Threads: 03-03-2003, 03:12 PM
  2. Insurance Woes, Help needed.

    By HOK in forum General Car/Bike Talk
    Replies: 9
    Latest Threads: 12-23-2002, 04:36 AM
  3. Not so good on nitrous... [email protected]

    By Toma in forum General Car/Bike Talk
    Replies: 8
    Latest Threads: 09-16-2002, 06:40 PM
  4. Nitrous Express group buy

    By Redlyne_mr2 in forum Miscellaneous Buy/Sell/Trade
    Replies: 0
    Latest Threads: 08-14-2002, 12:58 PM
  5. places to get zex nitrous kits in calgary?

    By 2000impreza in forum General Car/Bike Talk
    Replies: 42
    Latest Threads: 06-18-2002, 10:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •