Quantcast
loss of low/mid power... - Beyond.ca - Car Forums
Results 1 to 12 of 12

Thread: loss of low/mid power...

  1. #1
    Join Date
    Jun 2003
    Location
    Calgary
    Posts
    14
    Rep Power
    0

    Default loss of low/mid power...

    Hey guys, first post here, need some help with my cavalier if youre willing...

    its an 03, about 27k km's on it. about 3 weeks ago I started getting random RPM drops in all gears when I was below 3000 rpms. I'd have my foot on the pedal completely steady and I'd drop from 3000 to 2700 and then jump right back up. it's been getting progressively worse and now I get it all the time.

    couple of other related things. when I'm in neutral, parked (this was a couple of days ago) I was revving hard, and the engine would just bog down completely. I'd have my foot 3/4 of the way down on the pedal and the RPM's would go up to 2k, then just drop back to 1k and hover around 1500 until I released my foot (then the RPMs'd rise). Pretty much every time I move from a dead stop now I have to be really cautious not to stall because no matter how much gas I give, the RPMs stay at the dead idle 900 or so for a couple of seconds and then rise enough for me to shift into first. I have to wait about a week until I can get this looked at since I don't have time until then... does this seem like a serious problem or just something simple like a bad sensor?

    It doesnt happen at anything above 3k RPM, and it seems like my fuel mileage is getting worse too.

    thanks thanks...

  2. #2
    Join Date
    May 2002
    Location
    Calgary
    My Ride
    4cyl turbo diesel with a max speed of 10.9kmh
    Posts
    1,583
    Rep Power
    11

    Default

    shouldnt it have warranty? take it to the dealers man, dont touch it urself


    CONCRETE PATIO SPECIAL, PM ME FOR DETAILS!

  3. #3
    Join Date
    Aug 2003
    Location
    403
    My Ride
    1989 MA70, 2006 UZN215
    Posts
    1,931
    Rep Power
    10

    Default

    Originally posted by redline_13000
    shouldnt it have warranty? take it to the dealers man, dont touch it urself
    Yeah man, take it right away before something worse happens and it voids your warranty

  4. #4
    Join Date
    Apr 2003
    Location
    Red Deer, Alberta
    My Ride
    Really FAST Ones
    Posts
    410
    Rep Power
    0

    Default

    If it is an automatic the 300 rpm drop is probally your lockup converter and that is normal.
    Last edited by Dr. Lightspeed; 09-22-2003 at 01:42 PM.
    Lookin Good is Goin FAST
    "HOME of the AWD DYNO"

  5. #5
    Join Date
    Mar 2003
    Location
    C-Spot
    My Ride
    will molest you in 11 sec
    Posts
    2,235
    Rep Power
    12

    Default

    Sounds to me like its a sticky fuel injector or sumthin of the like. But in an 03 that is unheard of even for a GM. Definatley take that to the dealership and have it checked. The second incident sounds like a revlimiter that has gone haywire or sumthin, it could be a throttle position sensor or sumthin like that, but just take it to the dealership, should be covered under warranty

  6. #6
    Join Date
    May 2002
    Location
    c-town
    My Ride
    AI Servo
    Posts
    1,317
    Rep Power
    11

    Default

    Could also be an ignition problem (coilpack, wires,plugs). Take it to the dealer, man.

  7. #7
    Join Date
    Jun 2003
    Location
    403
    My Ride
    cd7 coupe
    Posts
    2,651
    Rep Power
    0

    Default

    is it standard?? my buddy had that problem in his CRX when his clutch was almost gone

  8. #8
    Join Date
    Sep 2003
    Location
    Calgary Alberta
    My Ride
    ...BNT0B0X...
    Posts
    8,728
    Rep Power
    17

    Default

    The TPS is what comes to mind for me...but being such a new car...take it to the dealer man...the hassle is totally not worth you messing things up...
    [email protected]larifjina...

  9. #9
    Join Date
    Jun 2003
    Location
    Calgary, ab
    My Ride
    Hemi, ZX6R
    Posts
    2,501
    Rep Power
    11

    Default

    Originally posted by Dr. Lightspeed
    If it is an automatic the 300 rpm drop is probally your lockup converter and that is normal.
    Originally posted by LKL
    Pretty much every time I move from a dead stop now I have to be really cautious not to stall because no matter how much gas I give, the RPMs stay at the dead idle 900 or so for a couple of seconds and then rise enough for me to shift into first.

  10. #10
    Join Date
    May 2002
    Location
    oreo cookie
    My Ride
    a wrx.
    Posts
    8,022
    Rep Power
    18

    Default

    27k is a lot of kms on a new car....what kind of maintenance have u done with the car?

  11. #11
    Join Date
    Mar 2003
    Location
    Brocket
    My Ride
    B18C5 neon -|-y|>3 r
    Posts
    1,933
    Rep Power
    0

    Default

    YOUR CAR IS NOT A NEON, THEREFOR YOU ARE NTO DRUNKL

  12. #12
    Join Date
    May 2003
    Location
    ReD DeeR, Ab
    My Ride
    94 Supra, 01 2.5rs
    Posts
    122
    Rep Power
    0

    Default

    new clutch!~~~~~~

Similar Threads

  1. Chris Chow's Twin Turbo GN, Runs mid to low [email protected]

    By Gripenfelter in forum Cars, Bikes, Machines
    Replies: 21
    Latest Threads: 02-13-2004, 12:47 AM
  2. low boost w/ med compression vs. high boost w/ low compression?

    By Ekliptix in forum General Car/Bike Talk
    Replies: 3
    Latest Threads: 11-14-2002, 08:12 PM
  3. Mid pipe

    By civic_rida in forum Performance Modifications
    Replies: 16
    Latest Threads: 08-14-2002, 12:29 PM
  4. wondering about prices on a mid-90s 325is, and possibly sc it

    By Impreza in forum General Car/Bike Talk
    Replies: 7
    Latest Threads: 07-10-2002, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •