Quantcast
Rogers technical support on Bold - Beyond.ca - Car Forums
Results 1 to 6 of 6

Thread: Rogers technical support on Bold

  1. #1
    Join Date
    Jun 2003
    Location
    Calgary
    My Ride
    C350 4matic
    Posts
    65
    Rep Power
    0

    Default Rogers technical support on Bold

    Hey guys, I'm currently using a Blackberry Bold and my bluetooth will not enable. I tried doing an OS reload and still nothing. So I get on the phone with Roger's support, and the guy tells me to do the reload again, but I have to wait 24 hours before I test the bluetooth.
    This is where my question is....why? If i'm just testing the OS, it either works, or it doesn't correct? Waiting 24 hours before I test the bluetooth shouldn't make a difference right?
    So anyways, I refused to do the wipe again because it takes time, so he hesitantly sent me a new one, but said that if they test it and are able to activate it, then I have to pay for it, so I'm a bit paranoid. Do you guys think my theory is right? Or does waiting 24 hours before testing it really matter? Thanks.

  2. #2
    Join Date
    Oct 2002
    Location
    NW Calgary
    My Ride
    GMC Sierra
    Posts
    115
    Rep Power
    0

    Default

    What are you trying to pair it with? Maybe something with wrong with the blue tooth device you're trying to pair with.

    waiting 24 hours is the dumbest thing i've heard sofar from those useless rogers techs. If it works it works, if it doesn't it doesnt. Unless rim has a proprietary count down timer for issues such as yours.

  3. #3
    Join Date
    Mar 2007
    Location
    Regina
    Posts
    466
    Rep Power
    0

    Default

    That tech probably goes on vacation in 24 hours haha

  4. #4
    Join Date
    Jul 2006
    Location
    Victoria Park
    My Ride
    '16 FoRS, '09 UZN215, '90 Z32, '15 Grom
    Posts
    3,406
    Rep Power
    18

    Default Re: Rogers technical support on Bold

    Originally posted by little_wan
    Hey guys, I'm currently using a Blackberry Bold and my bluetooth will not enable. I tried doing an OS reload and still nothing. So I get on the phone with Roger's support, and the guy tells me to do the reload again, but I have to wait 24 hours before I test the bluetooth.
    This is where my question is....why? If i'm just testing the OS, it either works, or it doesn't correct? Waiting 24 hours before I test the bluetooth shouldn't make a difference right?
    So anyways, I refused to do the wipe again because it takes time, so he hesitantly sent me a new one, but said that if they test it and are able to activate it, then I have to pay for it, so I'm a bit paranoid. Do you guys think my theory is right? Or does waiting 24 hours before testing it really matter? Thanks.
    Why didn't you ask him that? If you did, that would have gave you indication if it was just a BS response and he was trying to get rid of you.

    Call again and also mention the other tech said to wait 24 hours and see what he says.

  5. #5
    Join Date
    Aug 2008
    Location
    Calgary
    My Ride
    TDi
    Posts
    1,342
    Rep Power
    13

    Default

    How exactly is the bluetooth not working?

    Can you not find the device? I'm guessing its your cars bluetooth..
    Is it not pairing or you just can't get it to work?


    If you can't find your phone through your deck/navi, have you tried going into the bluetooth options and enabling the Discoverable feature?

    Also, 24 hours for what haha. Dumbest thing I've heard from a tech.
    GO FLAMES GO!

  6. #6
    Join Date
    Jun 2003
    Location
    Calgary
    My Ride
    C350 4matic
    Posts
    65
    Rep Power
    0

    Default

    Thanks for the response guys. When i told the service guy that it made no sense that I have to wait 24 hours to test the OS, he said "ok, is there anything else I can do for you today?". Which i responded "yes, give me a new phone". Then after some more arguing he reluctantly labeled it defective and threatened that if they tested it and it worked, then I would be charged.
    But it's defiantly the phone itself. I wasn't even able to enable the bluetooth, let alone pair it with anything.
    They sent me a new (refurbished) one and it pairs fine with everything. I'm just paranoid they'll find some dumb excuse to charge me for it.

Similar Threads

  1. Technical Support Specialist

    By syscal in forum Careers
    Replies: 0
    Latest Threads: 07-01-2009, 09:00 AM
  2. LF: IT Support/Desktop Support Work

    By Lagerstatten.ca in forum Careers
    Replies: 0
    Latest Threads: 03-19-2009, 09:16 AM
  3. support any chinese singer? who do u support?

    By kaishen in forum Entertainment
    Replies: 11
    Latest Threads: 10-22-2008, 01:43 PM
  4. Looking for technical support people

    By dgmartinez in forum Careers
    Replies: 3
    Latest Threads: 01-10-2007, 10:44 AM
  5. Replies: 15
    Latest Threads: 12-31-2006, 10:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •