Quantcast
Help! E36 being more annoying than a high maintenance high school girlfriend - Beyond.ca - Car Forums
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 21

Thread: Help! E36 being more annoying than a high maintenance high school girlfriend

  1. #1
    Join Date
    Jul 2008
    Location
    Calgary
    My Ride
    '09 Dodge Challenger
    Posts
    126
    Rep Power
    0

    Default Help! E36 being more annoying than a high maintenance high school girlfriend

    hey guys im stumped, need some help.

    My '94 320i died on me while on the road, i was driving for a half hour, and went to the automatic car wash and it was ok for 20 min. after coming to a stop, i accelerated to 3000 rpm and the car stuttered and then died. i tried to turn it on but it only cranked, it wouldnt fire up.

    - First thing that came to my mind was the DME got wet, so i popped the cover open and it was bone dry, there was even some dust on it. Checked the relay and still no go.

    - Second thing that came to my mind was the fuel supply. So i changed the relay. still no go, then I changed the fuel pump, still no go.

    - Third i thought it might be spark, so i grabbed some quick start and sprayed it into the intake, and the car ALMOST starts up, it'll ignite for maye a second and then die.

    Where should i go from here guys? Im taking the bus for now and im getting tired of the loud kids that take my route...

    Help.

  2. #2
    Join Date
    Nov 2002
    Posts
    3,680
    Rep Power
    24

  3. #3
    Join Date
    Oct 2004
    Location
    Calgary, AB
    My Ride
    2000 BMW 540i/6-spd & 2008 Triumph Street Triple
    Posts
    505
    Rep Power
    19

    Default

    My guess would be crank or cam position sensor (CPS)... quite common on the E36.
    Search Bimmerforums.com for answers. If that doesn't work take it to a independent BMW mechanic... don't just throw parts at it, it'll end up costing more in the end (that fuel pump you replaced was probably around $400 just for the part!).

  4. #4
    Join Date
    Jul 2006
    Location
    Calgary
    My Ride
    has three pedals.
    Posts
    2,975
    Rep Power
    0

    Default

    Hmm my car would run, but very poorly, even with a faulty intake cam shaft sensor.

  5. #5
    Join Date
    Jun 2008
    Location
    see-town
    Posts
    291
    Rep Power
    15

    Default

    Arguing over the internet is like cheering on the Oilers. Win or lose, you're still a dumbass.


    Originally posted by G-ZUS
    you mack daddy

  6. #6
    Join Date
    May 2002
    Location
    the C-spot
    My Ride
    O.P.P.
    Posts
    3,170
    Rep Power
    24

    Default Re: Help! E36 being more annoying than a high maintenance high school girlfriend

    Originally posted by eg_eric
    hey guys im stumped, need some help.

    My '94 320i died on me while on the road, i was driving for a half hour, and went to the automatic car wash and it was ok for 20 min. after coming to a stop, i accelerated to 3000 rpm and the car stuttered and then died. i tried to turn it on but it only cranked, it wouldnt fire up.

    - First thing that came to my mind was the DME got wet, so i popped the cover open and it was bone dry, there was even some dust on it. Checked the relay and still no go.

    - Second thing that came to my mind was the fuel supply. So i changed the relay. still no go, then I changed the fuel pump, still no go.

    - Third i thought it might be spark, so i grabbed some quick start and sprayed it into the intake, and the car ALMOST starts up, it'll ignite for maye a second and then die.

    Where should i go from here guys? Im taking the bus for now and im getting tired of the loud kids that take my route...

    Help.
    Eric, here are my replies to an older thread someone else posted awhile ago....
    Originally posted by cocoabrova
    Could also be your fuel pump relay, or the actual fuel pump. Or does it happen after you wash your car? OBD0 E36's are notorious for the DME's grounding out from accumulated water sitting underneath them (after going thru a touchless-type carwash or heavy rainfall)
    Originally posted by cocoabrova


    Well first off, stop using the touchless car washes if you can and just use the self-serve car washes, as the amount of water and water pressure is about half of what it would be going thru the touchless wash . Just by doing this, you will have eliminated your problem, but just as a precautionary measure, read over THIS page to gain some insight as to what exactly happens. Then I would search the net for some kind of fix to cure this i.e. building some sort of platform for the DME to avoid sitting in the pooled-up water.....

    Good luck
    The same exact sypmtoms happened to me right after washing my car, except it only took my car 10mins. to die Couldn't figure it out for the life of me, so I just stopped using the touchless car washes and !Voila! car's been running great ever since. The DME is obviously dry now, but you probably fouled your sparkplugs from all the cranking over. Change out your plugs and you should be good, but there is the possibilty that your DME fried, but get your plugs changed first and go from there. Call me if you want me to bring you in some.......

  7. #7
    Join Date
    Jul 2007
    Location
    Calgary
    My Ride
    Blue boy
    Posts
    4,893
    Rep Power
    21

    Default

    I hate the design of these cars. LOL I sold my 325 coupe to some guy last year and told him like 5 times(not exaggerating) not to take it to a touchless carwash and just wash it at home. He called me a week later from BC asking whats wrong with it because it won't start. He said he's at a car wash. I was like .

  8. #8
    Join Date
    Jul 2006
    Location
    Calgary
    My Ride
    has three pedals.
    Posts
    2,975
    Rep Power
    0

    Default

    I must admit, if we didn't have quirks, what would we bitch about online or try to diagnose? haha!

  9. #9
    Join Date
    Dec 2004
    Location
    Calgary
    My Ride
    2010 WRX Limited
    Posts
    410
    Rep Power
    19

    Default

    oh the e36.. fun car
    But once they get old.
    Everything just starts to go.

  10. #10
    Join Date
    Jul 2008
    Location
    Calgary
    My Ride
    '09 Dodge Challenger
    Posts
    126
    Rep Power
    0

    Default

    alright, sounds good thanks a lot guys, i'll try some of the things suggested and let you know either friday or saturday how it goes.

    cocoa, u have a pm...

  11. #11
    Join Date
    Aug 2008
    Location
    Lethbridge
    My Ride
    '08 AW E92 335i
    Posts
    1,078
    Rep Power
    16

    Default

    pics of the high school gf?

  12. #12
    Join Date
    Mar 2009
    Location
    403
    My Ride
    bimmer,benz, or bentley
    Posts
    268
    Rep Power
    14

    Default

    Originally posted by funkedelic2
    pics of the high school gf?

  13. #13
    Join Date
    Jul 2008
    Location
    Calgary
    My Ride
    '09 Dodge Challenger
    Posts
    126
    Rep Power
    0

    Default

    lmao, if i can fix it maybe i'll post the pics...

    But now my worst fears have come to light: The DME is fried and i know BMW charges an arm and leg for them...

    Anyone got a DME out there that i can grab from?

  14. #14
    Join Date
    Oct 2004
    Location
    Calgary, AB
    My Ride
    2000 BMW 540i/6-spd & 2008 Triumph Street Triple
    Posts
    505
    Rep Power
    19

    Default

    Originally posted by eg_eric
    lmao, if i can fix it maybe i'll post the pics...

    But now my worst fears have come to light: The DME is fried and i know BMW charges an arm and leg for them...

    Anyone got a DME out there that i can grab from?
    I thought you said the DME and the compartment were "bone dry"???

    'Cause that was my first guess when you said it quit after the car wash.

    Happened to my '93 325is... got a new used one for $350 from a member of Bimmerforums.com.

    Before you replace the DME make sure you clean out the 2 clogged cowl drain hoses behind the motor (dirt, leaves, etc.) or it will just happen again.

    Try Manchester on Glenmore Tr., they will likely have one... though probably expensive. You will also need to do some research on Bimmerforums to figure out which one you need.
    Last edited by GT4rally; 09-18-2009 at 10:08 PM.

  15. #15
    Join Date
    Jul 2007
    Location
    Calgary
    My Ride
    Blue boy
    Posts
    4,893
    Rep Power
    21

    Default

    try drying it out you might get lucky, my friend did

  16. #16
    Join Date
    Jul 2008
    Location
    Calgary
    My Ride
    '09 Dodge Challenger
    Posts
    126
    Rep Power
    0

    Default

    yeah it was bone dry (even had dust on it) but it looks like it was corrosion over time from previous wetting got to it.

  17. #17
    Join Date
    Jul 2008
    Location
    Calgary
    My Ride
    '09 Dodge Challenger
    Posts
    126
    Rep Power
    0

    Default car for sale

    still looking for a dme, or else i guess the car is for sale now guys if anyone out there wants to fix it. if you want details, pm me.
    Last edited by eg_eric; 09-21-2009 at 12:18 PM.

  18. #18
    Join Date
    Feb 2009
    Location
    Calgary
    My Ride
    Family Hauler
    Posts
    772
    Rep Power
    23

    Default

    Oh yea great idea listing your car FS in the same thread that lists it as unreliable!

  19. #19
    Join Date
    Oct 2004
    Location
    Calgary, AB
    My Ride
    2000 BMW 540i/6-spd & 2008 Triumph Street Triple
    Posts
    505
    Rep Power
    19

    Default Re: car for sale

    Originally posted by eg_eric
    still looking for a dme, or else i guess the car is for sale now guys if anyone out there wants to fix it. if you want details, pm me.
    Did you try calling Manchester? They will likely have one. If not Shenni's Auto Trend might be able to locate one.

  20. #20
    Join Date
    Oct 2004
    Location
    Calgary, AB
    My Ride
    2000 BMW 540i/6-spd & 2008 Triumph Street Triple
    Posts
    505
    Rep Power
    19

    Default

    OK, I just saw your ad on Kijiji for a DME... that passive searching will get you nowhere!

    If you haven't called Manchester Auto Parts or Shenni's, do it NOW!

    If you have, with no luck, do this:

    1. Sign up for Bimmerforums.com

    2. Scroll down to "Bimmer Parts For Sale"

    3. Search "e36 dme"

    Took me 3 minutes to find at least 5 DME's for sale for as low as $80 shipped!

    The 320i might be different than the 325i, so you need to know if yours is a "red-label" or "black-label" (I think) and the prefix at the end of the bar-code number, most likely "413".

    Don't sell it for next to nothing because you're too lazy to spend a couple hours doing some research... 'cause that's all it will take to save your ride dude!

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Priceline is being a little annoying

    By RickDaTuner in forum Travel and Vacation
    Replies: 2
    Latest Threads: 02-07-2010, 08:30 PM
  2. Input Survey for School Naming - New West Calgary High School

    By urban.one in forum Society / Law / Current Events / Politics
    Replies: 7
    Latest Threads: 05-22-2009, 09:04 AM
  3. fs: MY E36!! 1993 BMW E36 325i, M3 replica +more!

    By takemtochurch in forum BMW Marketplace
    Replies: 5
    Latest Threads: 03-25-2009, 12:18 AM
  4. fs: MY E36!! 1993 BMW E36 325i, M3 replica +more!

    By takemtochurch in forum Cars, Trucks, Motorbikes, and Trailers
    Replies: 4
    Latest Threads: 03-14-2009, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •