Quantcast
Need new furnace fan - Beyond.ca - Car Forums
Results 1 to 16 of 16

Thread: Need new furnace fan

  1. #1
    Join Date
    Jun 2007
    Location
    Calgary
    Posts
    100
    Rep Power
    0

    Default Need new furnace fan

    Can anyone recommend someone/company to come and replace the fan in my furnace? thx

  2. #2
    Join Date
    Mar 2010
    Location
    Calgary
    My Ride
    '16 GMC HD '94 MKIV SUPRA
    Posts
    201
    Rep Power
    0

    Default

    Its pretty easy to do yourself, I had to take mine out in my old house because it was rattling...turned out to be an alignment issue, lined it back up and slapped it in, all in all it took about an hour of my time.

  3. #3
    Join Date
    Jun 2007
    Location
    Calgary
    Posts
    100
    Rep Power
    0

    Default

    Originally posted by topsecret
    Its pretty easy to do yourself, I had to take mine out in my old house because it was rattling...turned out to be an alignment issue, lined it back up and slapped it in, all in all it took about an hour of my time.
    So where can I buy a replacement fan that is compatible???

  4. #4
    Join Date
    Dec 2009
    Location
    calgary
    Posts
    9
    Rep Power
    0

    Default

    Try arpi's:

    http://www.arpis.com/

    They sell furnace parts to the public.

  5. #5
    Join Date
    May 2005
    Location
    NE Calgary, AB
    My Ride
    TDI
    Posts
    1,086
    Rep Power
    9

    Default

    Plumbful Warehouse sells them too.

  6. #6
    Join Date
    Aug 2004
    Location
    Calgary
    Posts
    763
    Rep Power
    9

    Default

    Fan or motor ??

    Princess Auto has fan blower motors...

    Just get the right frame size and replace...
    2011 Ram 1500 QC Sport
    2012 Honda Accord EX-L Nav V6 6-Spd

  7. #7
    Join Date
    Nov 2005
    Location
    Calgary, Alberta
    My Ride
    2015 Hyundai Veloster
    Posts
    1,876
    Rep Power
    10

    Default

    I use a place down south just off Macleod by the go karts, begins with an A. I'll post it if I can remember it. They're awesome.
    Originally posted by Go4Long
    or else what? you'll turn on the caps lock?
    you do realize this is the internet right? lol
    Originally posted by rob the knob
    mar, you are good guy at heart
    you must realize your limitations
    then you will be happy if you fine place in live
    Originally posted by blitz
    Jesus man, I know you like Transformers, but you need to get out more. No one should get this upset over a movie based on children's toys.

  8. #8
    Join Date
    Dec 2006
    Location
    Calgary
    My Ride
    Built Ford Tough
    Posts
    3,045
    Rep Power
    12

    Default

    Sinclaire Supplies

  9. #9
    Join Date
    Jun 2006
    Location
    Calgary
    Posts
    2,455
    Rep Power
    10

    Default

    Funny you ask. I just had my fan motor fail last night. Replaced it today, was pretty straight forward if you are good with your hands n tools. I went to Benner Plumbing n Heating. First I tried a capacitor, $20, didn't do the trick, so I bought a new motor, $200. Unless you know for sure it's the motor, try a capacitor first, cheaper, and if you need a new motor it's a good precautionary measure to get a fresh capacitor anyways.

  10. #10
    Join Date
    Apr 2004
    Posts
    399
    Rep Power
    0

    Default

    Don't know if this will be the furnace problem thread or what but this just started happening to me the last couple of days so wondering if anyone has experienced this too.

    My furnace does not have a pilot light, but looks like elemental/electrical ignition. I see that come on, then it ignites and I see the flames. But about 15 seconds later, it turns off right before the fan comes on.

    So the fan goes for about 3 min or so and then turns off. It just keeps repeating this but since there's no heat or increase in temperature, it's following this pattern as the thermostat does not raise to the set temperature.

    Anyways, if anyone has experienced this, please post. Thanks.

  11. #11
    Join Date
    May 2010
    Location
    Vettel's #1
    My Ride
    Vettel's #1
    Posts
    1,176
    Rep Power
    7

    Default

    Originally posted by Euro838
    Don't know if this will be the furnace problem thread or what but this just started happening to me the last couple of days so wondering if anyone has experienced this too.

    My furnace does not have a pilot light, but looks like elemental/electrical ignition. I see that come on, then it ignites and I see the flames. But about 15 seconds later, it turns off right before the fan comes on.

    So the fan goes for about 3 min or so and then turns off. It just keeps repeating this but since there's no heat or increase in temperature, it's following this pattern as the thermostat does not raise to the set temperature.

    Anyways, if anyone has experienced this, please post. Thanks.
    I had something similar in my last house. Turns out the direct-vent to outside was plugged with ice and the furnace was shutting itself down after a few seconds as a safety feature.

  12. #12
    Join Date
    Apr 2004
    Posts
    399
    Rep Power
    0

    Default

    Thanks, I'll have to check it out. Yeah, that was what I was figuring was that it would start up but then something would cause the safety feature to kick in.

  13. #13
    Join Date
    Nov 2003
    Location
    Vernon, BC
    My Ride
    2017 Golf TSI
    Posts
    2,470
    Rep Power
    11

    Default

    Originally posted by CapnCrunch


    I had something similar in my last house. Turns out the direct-vent to outside was plugged with ice and the furnace was shutting itself down after a few seconds as a safety feature.
    Could also be the flame sensor. They tend to get some buildup on them and don't conduct as well as they need to. Very easy to clean if it is the problem.

    Check the board inside for blink codes and see what they tell you, that's the first place to start.
    Originally posted by Vagabond142
    Is the best game. Ever. In everness. It is more awesome than a robot caveman punching God in the dick. It is that awesome

  14. #14
    Join Date
    Nov 2005
    Location
    Calgary, Alberta
    My Ride
    2015 Hyundai Veloster
    Posts
    1,876
    Rep Power
    10

    Default

    Originally posted by Euro838
    Don't know if this will be the furnace problem thread or what but this just started happening to me the last couple of days so wondering if anyone has experienced this too.

    My furnace does not have a pilot light, but looks like elemental/electrical ignition. I see that come on, then it ignites and I see the flames. But about 15 seconds later, it turns off right before the fan comes on.

    So the fan goes for about 3 min or so and then turns off. It just keeps repeating this but since there's no heat or increase in temperature, it's following this pattern as the thermostat does not raise to the set temperature.

    Anyways, if anyone has experienced this, please post. Thanks.
    http://forums.beyond.ca/st/321570/is...th-my-furnace/

    Flame sensor
    Originally posted by Go4Long
    or else what? you'll turn on the caps lock?
    you do realize this is the internet right? lol
    Originally posted by rob the knob
    mar, you are good guy at heart
    you must realize your limitations
    then you will be happy if you fine place in live
    Originally posted by blitz
    Jesus man, I know you like Transformers, but you need to get out more. No one should get this upset over a movie based on children's toys.

  15. #15
    Join Date
    Apr 2004
    Posts
    399
    Rep Power
    0

    Default

    Mar ^^ Thanks, I was just going to post that it was a dirty flame sensor. I swapped the flame sensor from my working furnace and it fired up and stayed on as it should. Then I cleaned off the flame sensor with the issue, then it resolved the problem. I'm glad I got this fixed before real winter hits next week. Would have been brutal!

  16. #16
    Join Date
    Nov 2005
    Location
    Calgary, Alberta
    My Ride
    2015 Hyundai Veloster
    Posts
    1,876
    Rep Power
    10

    Default

    Glad we could help!
    Originally posted by Go4Long
    or else what? you'll turn on the caps lock?
    you do realize this is the internet right? lol
    Originally posted by rob the knob
    mar, you are good guy at heart
    you must realize your limitations
    then you will be happy if you fine place in live
    Originally posted by blitz
    Jesus man, I know you like Transformers, but you need to get out more. No one should get this upset over a movie based on children's toys.

Similar Threads

  1. furnace fan will not turn off

    By thetransporter in forum Real Estate / Finance
    Replies: 15
    Latest Threads: 02-05-2014, 02:50 AM
  2. Need a new furnace soon, what to budget

    By cidley69 in forum Real Estate / Finance
    Replies: 11
    Latest Threads: 01-18-2010, 04:05 PM
  3. Furnace help!? Any Furnace techs on Beyond?

    By BMDUBS in forum Home and Garden
    Replies: 11
    Latest Threads: 12-13-2009, 12:59 PM
  4. F/S: Sr20det Custom Fan Shroud With Fan

    By sr20s14zenki in forum Automotive Parts [Mechanical Parts]
    Replies: 0
    Latest Threads: 10-24-2009, 11:38 PM
  5. FS: AMD 64/64x2 Heatsink/Fan & Intel 478 Socket Heatsink/Fan

    By eblend in forum Computer Hardware & Peripherals
    Replies: 0
    Latest Threads: 08-13-2005, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •