Quantcast
Ford Trucks Thread WAS:EcoBoost Thread - Page 87 - Beyond.ca - Car Forums
Page 87 of 87 FirstFirst ... 77 86 87
Results 1,721 to 1,737 of 1737

Thread: Ford Trucks Thread WAS:EcoBoost Thread

  1. #1721
    Join Date
    Dec 2008
    Location
    Calgary
    My Ride
    18’ F-150
    Posts
    2,885
    Rep Power
    13

    Default

    My truck battling the elements with the cold and shit roads. Still running the factory Hankooks and I’m really not too impressed. Trying to decide between duratracs or KO2’s for the next set. Think I can get away with a 33 with minimal rubbing (2.5 level)

    vault tec experiments

    EDIT: If anybody is interested I have a set of OEM ford mudflaps (The plastic ones) that go over factory OEM flares. All hardware included. Asking $80 for them in SW Calgary. Also got a set of OEM flares Oxford White. Asking $80 for those too.
    Last edited by Shlade; 02-18-2019 at 02:33 PM.

  2. #1722
    Join Date
    Aug 2012
    Location
    N/A
    Posts
    36
    Rep Power
    0

    Default

    Anyone else having intermittent heat loss? Only thing I've found on the internet is a TSB for 2015/2017 block heaters. My truck started doing this yesterday where it will blow cold air for about 5 minutes then blow warm air for a couple minutes and continuously do this. I have a road trip coming up this weekend and the dealership can't look at it till next week sometime. Also getting intermittent satellite radio loss too. All these issues are starting to really piss me off. Trucks sitting at 6000KM.

  3. #1723
    Join Date
    Jan 2006
    Location
    Calgary
    My Ride
    17' Camaro SS 1LE, 17' Golf R, 18' F-150
    Posts
    2,281
    Rep Power
    16

    Default

    Quote Originally Posted by stillworking View Post
    This quote is hidden because you are ignoring this member. Show Quote

    My new Lead Foot Grey F-150.
    You've got good taste


    Quote Originally Posted by Shlade View Post
    This quote is hidden because you are ignoring this member. Show Quote
    My truck battling the elements with the cold and shit roads. Still running the factory Hankooks and I’m really not too impressed. Trying to decide between duratracs or KO2’s for the next set.

    I've found the Hankooks to be no no better or worse than other snowflake rated truck tires i.e. Nokian Rotiva's, aka decent in fresh snow and shit on ice/hard packed snow. I think I'm going to invest in a set of winters for next year.

  4. #1724
    Join Date
    Sep 2007
    Location
    Calgary
    My Ride
    golfR
    Posts
    313
    Rep Power
    0

    Default

    Quote Originally Posted by 94boosted View Post
    This quote is hidden because you are ignoring this member. Show Quote
    You've got good taste





    I've found the Hankooks to be no no better or worse than other snowflake rated truck tires i.e. Nokian Rotiva's, aka decent in fresh snow and shit on ice/hard packed snow. I think I'm going to invest in a set of winters for next year.
    Which ones do you have in mind?
    I'll be shopping around for a set too. While the stock tires have been decent it's not the best for winter.
    I might be limited on size as I want to use the Raptor wheels for the winter.

  5. #1725
    Join Date
    Mar 2005
    Location
    Calgary
    My Ride
    Protege 5 Turbo / Ecoboost FX4
    Posts
    1,102
    Rep Power
    16

    Default

    Quote Originally Posted by Matty_10 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Anyone else having intermittent heat loss? Only thing I've found on the internet is a TSB for 2015/2017 block heaters. My truck started doing this yesterday where it will blow cold air for about 5 minutes then blow warm air for a couple minutes and continuously do this. I have a road trip coming up this weekend and the dealership can't look at it till next week sometime. Also getting intermittent satellite radio loss too. All these issues are starting to really piss me off. Trucks sitting at 6000KM.
    My ‘13 occasionally gets the “air mix door actuator” issue where I’ll have no heat. There was a TSB for it but I never got it done. Not sure if it’s the same issue.

  6. #1726
    Join Date
    Jan 2006
    Location
    Calgary
    My Ride
    17' Camaro SS 1LE, 17' Golf R, 18' F-150
    Posts
    2,281
    Rep Power
    16

    Default

    Quote Originally Posted by chongkee_ View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Which ones do you have in mind?
    I'll be shopping around for a set too. While the stock tires have been decent it's not the best for winter.
    I might be limited on size as I want to use the Raptor wheels for the winter.
    I'm a big fan of el cheapo studded tires for winter (Sailun, Weslake, etc.), 95% of the performance of Hakka's at 35% of the price

  7. #1727
    Join Date
    Oct 2004
    Location
    Calgary/Alberta
    My Ride
    '17 F150 FX4 sport, '10 VW GTI 5d
    Posts
    879
    Rep Power
    15

    Default

    46K on my Hankooks and I don't feel they are that bad at all. At work I drive an SUV with Blizzaks on it all day, and the only difference I feel is the weight distribution of the vehicle.
    sig deleted by moderator, click here for info

  8. #1728
    Join Date
    Jul 2008
    Location
    Calgary, Alberta
    My Ride
    '16 F150 Lariat, SW20 MR2
    Posts
    1,563
    Rep Power
    12

    Default

    I agree with the above. I find them fine for most driving. in ice they are obviously not fantastic, but in snow and dry, no complaints. I do also find them predictable.

  9. #1729
    Join Date
    Aug 2012
    Location
    N/A
    Posts
    36
    Rep Power
    0

    Default

    Quote Originally Posted by Matty_10 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Anyone else having intermittent heat loss? Only thing I've found on the internet is a TSB for 2015/2017 block heaters. My truck started doing this yesterday where it will blow cold air for about 5 minutes then blow warm air for a couple minutes and continuously do this. I have a road trip coming up this weekend and the dealership can't look at it till next week sometime. Also getting intermittent satellite radio loss too. All these issues are starting to really piss me off. Trucks sitting at 6000KM.
    Ended up having next to no coolant left.... not sure how this happened.

  10. #1730
    Join Date
    Jan 2008
    Location
    McDonalds Wifi
    My Ride
    100% SAVAGE
    Posts
    5,485
    Rep Power
    22

    Default

    Quote Originally Posted by Matty_10 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Ended up having next to no coolant left.... not sure how this happened.
    That's weird, where was it going? Leaking out, or getting burned or what?
    Quote Originally Posted by KPHMPH View Post
    This quote is hidden because you are ignoring this member. Show Quote
    You guys are the worst group of people Iíve spoken to today.

  11. #1731
    Join Date
    Oct 2005
    Location
    Red Deer, Alberta
    My Ride
    1995 WRX STi
    Posts
    1,529
    Rep Power
    16

    Default

    Quote Originally Posted by Matty_10 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Ended up having next to no coolant left.... not sure how this happened.
    Um... there definitely should be a low coolant level light. So I am very curious as to how this happened.
    sig deleted by moderator, click here for info

  12. #1732
    Join Date
    Aug 2012
    Location
    N/A
    Posts
    36
    Rep Power
    0

    Default

    There was no low coolant warning light, truck goes in Thursday to see what the fuck is going on. I’ve already added a jug of Prestone and the coolant is back to well below MIN. Truck cab does have a funky coolant smell to it and I’m getting terrible gas mileage tho not sure if that has anything to do with anything. At this rate I’m gonna have to start the lemon process.

  13. #1733
    Join Date
    Dec 2008
    Location
    Calgary
    My Ride
    18’ F-150
    Posts
    2,885
    Rep Power
    13

    Default

    Quote Originally Posted by Matty_10 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    There was no low coolant warning light, truck goes in Thursday to see what the fuck is going on. I’ve already added a jug of Prestone and the coolant is back to well below MIN. Truck cab does have a funky coolant smell to it and I’m getting terrible gas mileage tho not sure if that has anything to do with anything. At this rate I’m gonna have to start the lemon process.
    There is no lemon process in Canada? Ford will fix it... hope you’re not tuned or anything

  14. #1734
    Join Date
    Jul 2008
    Location
    Calgary, Alberta
    My Ride
    '16 F150 Lariat, SW20 MR2
    Posts
    1,563
    Rep Power
    12

    Default

    Just posting because. I have a chunk of ice stuck between the bed and cab, and the rattling is driving me BONKERS. They did a great job at road noise insulation, but anything actually hitting bodywork sounds amplified.

  15. #1735
    Join Date
    Jan 2008
    Location
    McDonalds Wifi
    My Ride
    100% SAVAGE
    Posts
    5,485
    Rep Power
    22

    Default

    Quote Originally Posted by ShermanEF9 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Just posting because. I have a chunk of ice stuck between the bed and cab, and the rattling is driving me BONKERS. They did a great job at road noise insulation, but anything actually hitting bodywork sounds amplified.
    Go visit the new horizon mall heated parking for an hour.
    Quote Originally Posted by KPHMPH View Post
    This quote is hidden because you are ignoring this member. Show Quote
    You guys are the worst group of people Iíve spoken to today.

  16. #1736
    Join Date
    Jan 2006
    Location
    Calgary
    My Ride
    17' Camaro SS 1LE, 17' Golf R, 18' F-150
    Posts
    2,281
    Rep Power
    16

    Default

    Quote Originally Posted by ShermanEF9 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    Just posting because. I have a chunk of ice stuck between the bed and cab, and the rattling is driving me BONKERS. They did a great job at road noise insulation, but anything actually hitting bodywork sounds amplified.
    It's like driving around in a tin can

    I actually find the sound of rocks hitting when driving super annoying, even though I have mud guards, 3M'd my rockers and wheel well liners.

  17. #1737
    Join Date
    May 2004
    Location
    Calgary
    Posts
    744
    Rep Power
    0

    Default

    First winter I was running on the 20" Hankooks which was fine most of the time with nearly full tread depth but had a scare one time driving on an icy downhill (one that I take every single day). Now I am on my second season of Blizzak DM V2 and they have been very impressive in the snow and ice, especially in 4A mode. I usually just run on 2H mode because or else I will be doing speeds that are a lot faster than other cars out there.

Page 87 of 87 FirstFirst ... 77 86 87

Similar Threads

  1. Replies: 32
    Latest Threads: 08-01-2014, 05:24 AM
  2. Replies: 24
    Latest Threads: 01-10-2014, 07:08 PM
  3. 2013 Ford F150 /w Ecoboost

    By puya.ro in forum General Car/Bike Talk
    Replies: 3
    Latest Threads: 07-05-2012, 10:31 AM
  4. FS: 2010 Black Ford Flex LTD AWD Ecoboost

    By lint in forum Cars, Trucks, Motorbikes, and Trailers
    Replies: 0
    Latest Threads: 05-22-2012, 10:14 AM
  5. The crazy Ford Ecoboost 3.5L V6 test

    By Cos in forum General Car/Bike Talk
    Replies: 83
    Latest Threads: 02-05-2011, 12:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •