Quantcast
Smell of gas inside after parked for awhile?!??! - Beyond.ca - Car Forums
Results 1 to 9 of 9

Thread: Smell of gas inside after parked for awhile?!??!

  1. #1
    Join Date
    Aug 2017
    Location
    'Berta
    My Ride
    A bunch of Nissans..duh.
    Posts
    178
    Rep Power
    0

    Default Smell of gas inside after parked for awhile?!??!

    2009 Murano, 280,000km

    So today, right when I'm getting off Deerfoot to get back in Airdrie, I all of the sudden notice a strong smell of gas (or maybe exhaust?) inside my car. I thought nothing of it as I thought it was coming from outside and the smell seemed to almost disappear to nothing by the time I pull into my driveway.

    Then about a half hour later I get back in, strong smell again but nothing in the outside air so I know it's my car...I drive off, it goes away. Park at the clinic and come back out an hour an half later, same thing, smells like gas. Drive back home nothing while it's running, get home, no smell, just went out, still smell gas...

    I have owned over 25 different used cars in my life, have never come across this and can't seem to find anything similar online...it's mostly people smelling gas while driving...any help?

    Could it be an exhaust leak of some kind, as I have had the P0420 code come on twice over the past 2 weeks, but it hasn't come on since...I cleared it as I have this code on previous Nissans before and it is commonly known issue on Nissans, emmission sensor related and doesn't affect the drive.

    Another thing I came across on a Nissan forum was that maybe a gas line runs through the trunk just behind the inner panels and maybe that is leaking? I have not noticed a huge drop in my gas gauge though...
    Last edited by NissanFanBoy; 01-11-2018 at 09:38 PM.

  2. #2
    Join Date
    Dec 2008
    Location
    Calgary
    Posts
    147
    Rep Power
    0

    Default

    Bad o2 sensor causing your engine to run rich? Might throw the cat sensor off too.

  3. #3
    Join Date
    Aug 2017
    Location
    'Berta
    My Ride
    A bunch of Nissans..duh.
    Posts
    178
    Rep Power
    0

    Default

    Quote Originally Posted by J-D View Post
    Bad o2 sensor causing your engine to run rich? Might throw the cat sensor off too.
    But would that result in the smell of gas inside after being parked?

  4. #4
    Join Date
    Dec 2008
    Location
    Calgary
    Posts
    147
    Rep Power
    0

    Default

    Quote Originally Posted by NissanFanBoy View Post
    But would that result in the smell of gas inside after being parked?
    Probably not to the extent you're describing, just something to keep in mind if you check the fuel lines and tank and don't find anything...

  5. #5
    Join Date
    Jan 2008
    Location
    calgary
    My Ride
    OM642
    Posts
    1,023
    Rep Power
    12

    Default

    Check fuel lines, my old G35 had this issue once and one of the connections was cracked.
    The access was below the rear seat in the G35, not sure where it would be in the Murano.

  6. #6
    Join Date
    Jul 2004
    Location
    YYC
    Posts
    2,834
    Rep Power
    16

    Default

    Wondering if a emissions vent is frozen up causing the tank to pressure up and vent off elsewhere or something like that.
    Or Gas cap not sealing. I know that can cause that ECU code you said.

  7. #7
    Join Date
    Sep 2004
    Location
    Calgary
    My Ride
    2017 Civic Hatch ST
    Posts
    8,902
    Rep Power
    22

    Default

    The two times I have experienced this, one was a leaky fuel tank seal (there was one on the top apparently, just under my rear passenger compartment), and also in the cold when cars run really rich.

  8. #8
    Join Date
    Aug 2017
    Location
    'Berta
    My Ride
    A bunch of Nissans..duh.
    Posts
    178
    Rep Power
    0

    Default

    I sincerely hope it is extreme cold related because nothing happened today at all

  9. #9
    Join Date
    Jan 2008
    Location
    Calgary
    Posts
    59
    Rep Power
    0

    Default

    Quote Originally Posted by NissanFanBoy View Post
    I sincerely hope it is extreme cold related because nothing happened today at all
    Probably a seal on a fuel fitting in your engine bay. Iíve seen a few vehicles where they leak once it gets to extreme cold.

Similar Threads

  1. Car has foul smell after using AC

    By Hero_X in forum Car Care, Detailing and Body Work
    Replies: 14
    Latest Threads: 04-24-2017, 07:39 AM
  2. thread from awhile back

    By streetarab in forum Photographer's Corner
    Replies: 10
    Latest Threads: 12-13-2006, 07:58 PM
  3. Gas smell

    By gpomp in forum Mechanical
    Replies: 22
    Latest Threads: 08-03-2003, 11:20 AM
  4. Gas smell in garage...

    By Ashkente in forum Mechanical
    Replies: 5
    Latest Threads: 03-26-2003, 05:17 PM
  5. Gas Smell from Muffer????

    By Azn_dailo in forum General Car/Bike Talk
    Replies: 7
    Latest Threads: 12-06-2002, 04:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •