Quantcast
2019 CX3 Battery issue - Page 3 - Beyond.ca - Car Forums
Page 3 of 3 FirstFirst ... 2 3
Results 41 to 45 of 45

Thread: 2019 CX3 Battery issue

  1. #41
    Join Date
    Nov 2002
    Location
    Chinatown
    My Ride
    FJC, S30
    Posts
    2,372
    Rep Power
    22

    Default

    I was having this issue with my car. Kept on getting new batteries under warranty. What I found out is that my car only charges enough for what I'm using, smart altetnator and smart charging for emissions on these new cars.

    I got my most recent battery checked while at my friends shop. It was 58% charged (after 6 months of driving) but the battery healthy was 100%. I got it on a tender to fully charge and then proceeded to drive it a few more months and tested it again to see. 98% charged and 100% healthy.

    That leads me to think that batteries from the dealer are not fully charged leading to premature failure. Secondly the newer cars only charge enough to run what your are using. Its not like our old cars where you sit and rev the engine and it charges.
    Submaker.Illest.

  2. #42
    Join Date
    Jul 2004
    Location
    YYC
    Posts
    3,596
    Rep Power
    44

    Default

    After working at a dealer, you'll see how often vehicles sit and need a boost before a customer shows up.

  3. #43
    Join Date
    Jan 2004
    Location
    Calgarian Living in Edmonton
    My Ride
    93 240sx SE, 17 Infiniti Q50S, 2008 Highlander
    Posts
    6,557
    Rep Power
    27

    Default

    Quote Originally Posted by mr2mike View Post
    This quote is hidden because you are ignoring this member. Show Quote
    After working at a dealer, you'll see how often vehicles sit and need a boost before a customer shows up.
    Real talk. Customer vehicle was ready for pick up. Porter grabbed it from out back, parked it in the drive through breezeway. Customer here, paid bill. Went out to drive off, car wouldnt start.... lol
    Originally posted by GTS Jeff
    You know those bored stay at home moms who's entire lives revolve around driving their kids to soccer, various cleaning accessories, and worrying about neighbourhood rapists? The kind of people that watch the View and go "uh huh..." Those unfulfilled people who try to fill the void in their empty lives by writing whiny letters to the editor complaining about shit that no one really cares about?

    Well imagine if instead of writing that letter to the editor, she just posts on a car forum for car enthusiasts. That's Kritafo.

  4. #44
    Join Date
    Jan 2012
    Location
    calgary
    Posts
    26
    Rep Power
    0

    Default

    Quote Originally Posted by mr2mike View Post
    This quote is hidden because you are ignoring this member. Show Quote
    There are ways to check parasitic drain.
    Multimeter and start pulling fuses and have a friend check the readings. That'll help narrow it.
    Try jabjabs circuit first.
    The dealers have done a parasitic drain inspection, but I remain skeptical.

  5. #45
    Join Date
    Jan 2008
    Location
    Calgary
    My Ride
    Unicycle
    Posts
    10,854
    Rep Power
    100

    Default

    There's three ways to fix this, the easy way, the hard way and the even harder way. All are laid out in this thread.
    Quote Originally Posted by rage2 View Post
    This quote is hidden because you are ignoring this member. Show Quote
    I almost shat myself after eating way too much at lunch with @killramos so ya, we can start the diaper thread now.

Page 3 of 3 FirstFirst ... 2 3

Similar Threads

  1. FS: FS: 225/50/18 Michelin X-ice tires w/ OEM Mazda CX3 GT Wheels

    By eglove in forum Automotive Parts [Wheels/Tires]
    Replies: 20
    Latest Threads: 09-17-2020, 08:38 AM
  2. Crv, hrv, cx3, cx5??

    By duckley in forum Trucks, 4x4 and Offroading Zone
    Replies: 22
    Latest Threads: 07-15-2017, 08:11 PM
  3. Old S3 battery issue

    By Skrilla in forum Computers, Consoles, and other Electronics
    Replies: 4
    Latest Threads: 05-19-2015, 02:51 PM
  4. Battery or phone issue

    By schurchill39 in forum Computers, Consoles, and other Electronics
    Replies: 1
    Latest Threads: 10-15-2011, 12:10 PM
  5. Alternator issue caused by moto battery?

    By 240SX92 in forum Nissan 240sx / Silvia Owners
    Replies: 7
    Latest Threads: 05-09-2011, 12:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •