Quantcast
FUTURESHOP deck install nightmare... - Beyond.ca - Car Forums
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 22

Thread: FUTURESHOP deck install nightmare...

  1. #1
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default FUTURESHOP deck install nightmare...

    Today, I bought a JVC mp3 deck from FUTURESHOP and all I wanted was the deck and I was gonna install it myself. But then the sale guy told me that he'd give me the install for free, so I was like, cool, save me an hr or so...
    WORST MISTAKE OF MY LIFE!!!
    I didn't think it was possible to screw up a deck install cause well.. you get the harness, match the proper wires to the right colors... plug and play...
    This install dude took 3 hrs, installed the deck, turned it on, only front speakers work! No sound from the rear speakers! Then buddy thinks that's it's the AFBS amp that's in the rear speakers causing the problem and started cutting the wires to the amp to "bypass" it so it'd work. I frequent PreludeOnline.com and I've NEVER EVER heard of anyone who has an aftermarket deck that NEEDS to have the AFBS amp removed before it'd work. After arguing with him for a good while telling him that the stock speakers sound like crap if the amp with removed, he told me to come back tomorrow to get his manager to take a look at it. So, ok, we'll see what happens then.
    If this is the end of the story, I wouldn't be as ticked off as I am now... When I was driving away, I noticed that my shiftknob felt dirty, so I wiped it with my thumb and then that's when I realized that that's not dirt, it's a freakin SCRATCH!!! 2 OF THEM!!! That's my $100 Momo CF shiftknob buddy scratched when he forcefully removed my factory deck from the install bay!!! I've never felt so pissed off yet speechless before... I can't believe I trusted "professionals" to install my deck especially at a brand name store like FUTURESHOP. I'm truly disappointed at them and their employees and their quality of service (or lack of)... If they don't do anything to compensate for the damage they've done to my car, I swear they will never hear the end of me badmouthing them to everyone I know...
    I will update everyone of what happens tomorrow...

  2. #2
    Join Date
    Oct 2002
    Location
    Calgary
    My Ride
    94 BMW 320i
    Posts
    144
    Rep Power
    0

    Default

    dude what location was this??? so i never go there again!?

  3. #3
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    Macleod Trail & Glenmore

  4. #4
    Join Date
    Jun 2002
    Location
    Calgary, Alberta
    My Ride
    Subaru Outback
    Posts
    1,023
    Rep Power
    23

    Default

    I worked in the computer department of Future Shop for 6 years way back when I just finished high school.

    To be honest, this type of stuff does not surprise me.

    Only go to FS to buy stuff for the cheap prices. Don't expect any type of decent service.

  5. #5
    Join Date
    Jun 2002
    Location
    Calgary
    My Ride
    Chevy Colorado ZR2
    Posts
    1,586
    Rep Power
    23

    Default

    that sucks big time man, maybe they used your prelude as a guinea pig to the new installers or something, you should complain to the manager tomorrow and tell them to throw you a new harness and install it yourself just to make sure it doesn't mess up again

  6. #6
    Join Date
    May 2002
    Posts
    451
    Rep Power
    21

    Default

    There was no reason why he should have bypassed the AFBS unit. I installed my unit, like you said all you need to do is plug the wires into the harness.

  7. #7
    Join Date
    Jul 2002
    Location
    Calgary
    My Ride
    2016 VW MK7 R ORYX DSG TECH
    Posts
    903
    Rep Power
    20

    Default

    yeah, I totally don't trust those guys at FS or A&B because anybody can work there. They can be a person who's been doing it for years or some punk kid who's had experience installing decks for friends etc and has no regards to ur property at all (and this seems to be the case).

    I'm always scared that if I get something nice installed from them that some ppl working there to get ur license plates # and then steal it from you later.

    You should talk to the manager and never let them heard the end of it until you get a free deck or something. Try complaining to FS canada's headquarters.
    "Sic Parvis Magna"
    FKA Silver_SpecV

  8. #8
    Join Date
    May 2002
    Location
    403
    My Ride
    UFA
    Posts
    10,343
    Rep Power
    48

    Default

    Oh dude, sorry to hear man!

    There are only a few installers around the city that I trust with my parts, [email protected]&B Shawnessy, [email protected] [email protected] Macleod and maybe LUDELVR
    Conversations like this can be intense.

  9. #9
    Join Date
    May 2002
    Location
    403
    My Ride
    UFA
    Posts
    10,343
    Rep Power
    48

    Default

    And since when did it take 3 hours to install a deck? It took 5 mins on my Prelude!!!
    Conversations like this can be intense.

  10. #10
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    Just found this on yahoo group hondaprelude:
    > > i just put in a cd player in my 98 lude. My front speakers work fine and so do my subs but for some reason the rear speakers arent working. They sometimes cut in when i turn it up high. I checked all the wiring twice and replugged all the harnesses. Does anyone kno what this could be.
    reply to that is:
    > > I'm assuming you're running your rear speakers straight off the head unit and not on a seperate amp. The problem is there is a factory amp (w/ the abfs or afbs or whatever) and some head units will not work with it. My old head unit (Kenwood KDC PS709) works great with the factory amp, but my new
    Clarion wont. I'm running aftermarket amps on everything now.
    So, I guess JVC and Clarion doesn't work with the AFBS, but Pioneer and Kenwood does. I wonder what's the diff between these brands?

  11. #11
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    Found this too on Gary Prelude Audio page:
    So, looks like if the install dude would have bypass the AFBS amp, it would have worked, but it would have fryed my new deck!!! good job buddy...

    AFBS -- Acoustic FeedBack System
    This is the part everyone wants to know about, as it is unconventional for a car audio system. What it does is analyze the sound from the rear speakers for distortion, then feeds that information back into the amplifier to help eliminate it. This is similar in concept to how the servo subwoofer that might be in your home audio system works.

    Each rear speaker has a microphone attached. Under the right-rear speaker, there is a small box that is both a small amplifier and the feedback system. Apparently, the head-unit has nothing to do with AFBS (despite the label affixed upon the front)! Normal speaker outputs are sent to the rear, which is amplified by the AFBS box. The AFBS unit sends a monophonic signal to both of the rear speakers. Yes, that's right, the rear is wired in mono. No, you can't change how the AFBS does that. (This is not as bad as it first seems -- most of us on the Prelude lists didn't even notice until someone brought it up! It's extremely difficult to detect the lack of stereo in the rear, because the audio image should be coming from the front part of the car. Personally, I ran my stock setup with it faded quite a bit towards the front.)

    There is one other important peice of information about the rear speakers -- they are 2 ohm speakers, not the usual 4 ohm. The consequence of this is that you will overheat the head-unit if you attempt to connect these to a typical head-unit; most aftermarket amps can handle 2 ohms. There's only so much modification that can be done with the rears. (If you disable AFBS, I recommend replacing the rear speakers as well, or running them with an aftermarket amp; do not hook up the rear speakers to a head-unit.) The advantage of 2 ohm speakers is that they are twice as loud as 4 ohm speakers, so with AFBS, the tiny amp, and 2 ohm speakers, everything combined puts out pretty good bass in a stock system, and saves the limited trunk space. As a system, it does what it is designed to do; since it is a system (a combination of 2-ohm speakers, microphones, and an amp), modifying part of the system is difficult. In general, either like it, or replace the system (rear speakers & unplug the rear amp).

  12. #12
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    Aiwa decks don't work on 5th gen preludes with AFBS either... damn! should have done more research before purchasing...

    Uhh...i dont know if i agree with that. Mind if i ask if you've done some audio work? the only reason i ask is that i tried to install my own HU (the aiwa mp3 player) and could not for the life of me get the damn rear speakers to work. I knew the connections were right...everythign was right...but no sound out of the rear speakers. I even replaced the damn stockers with some eclipses...btu still no sound (front still sounded ok, but no rear). I finally took it to best buy, where the guy just bypassed the
    AFBS, and that was the only way to get it to work.

  13. #13
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    Originally posted by 5gluder
    There was no reason why he should have bypassed the AFBS unit. I installed my unit, like you said all you need to do is plug the wires into the harness.
    What brand's your deck?

  14. #14
    Join Date
    May 2002
    Posts
    451
    Rep Power
    21

    Default

    Originally posted by sml


    What brand's your deck?
    I got an Alpine, but the factory unit is also made by Alpine. I have never encountered this problem, although all my decks were Alpine. The articles you posted sound right, I don't know how the speakers will sound without the AFBS unit. You may have to replace your 6x9's, which will turn out to be more of a pain for you. Maybe see if they will exchange the deck

  15. #15
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    Anyone got any idea what's the difference between these decks that might lead it not to be compatible with my factory amp?

    works:
    Alpine
    Pioneer
    Kenwood

    Doesn't work:
    JVC
    Clarion
    Aiwa

    thx!

  16. #16
    Join Date
    Jun 2002
    Location
    Calgary, Alta
    Posts
    1,188
    Rep Power
    22

    Default

    you should've gone for a alpine mp3 deck in the first place man!!! the jvc just doesnt compare, alpine is a little more, but the technology is so much better, it takes forever searching for mp3's on the jvc unit

  17. #17
    Join Date
    May 2002
    Posts
    451
    Rep Power
    21

    Default

    Maybe they use the same type of chipsets

  18. #18
    Join Date
    Jul 2002
    Location
    Calgary/Helsinki
    My Ride
    GTI
    Posts
    3,823
    Rep Power
    23

    Default

    Yeah, I'd never trust the future shop, especially the one on Macleod, my mom hated the people working there, when we were shopping for our home theater we dropped in there, then left right away, same thing with when I got my deck (alpine). Ended up getting all my stuff from Soundsaround on Macleod, it's the way to go. Good service, and good people for the most part, Firoz is the man, sometimes I go there he just wants to chill with me, he doesn't even try to sell me stuff half the time, he's a good man.

  19. #19
    Join Date
    Jul 2002
    Location
    Cowtown
    My Ride
    08 VQ35HR
    Posts
    765
    Rep Power
    21

    Default

    UPDATE: The install manager have agreed to compensate me for a new shiftknob. Very professionally handled, I was quite impressed! Also, I was a bit calmer the next day when i talked to him. So, everything's back to normal now... FS did it right this time.

  20. #20
    Join Date
    Oct 2002
    Location
    South
    My Ride
    1993 240; 2003 R6
    Posts
    26
    Rep Power
    0

    Default

    People make mistakes, If you give situations a day or two to cool down more resolutions are often made.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Traffic is a nightmare

    By mrmattyk in forum General
    Replies: 1
    Latest Threads: 12-14-2002, 06:24 PM
  2. KICKER COMP VR 10" subs - KENWOOD DECK - KICKER AMP - TRUNK INSTALL

    By frenchdriver in forum Miscellaneous Buy/Sell/Trade
    Replies: 9
    Latest Threads: 12-11-2002, 09:38 PM
  3. bmw nightmare in vancouver

    By e46slugmo in forum General Car/Bike Talk
    Replies: 8
    Latest Threads: 12-01-2002, 05:50 PM
  4. Tire Install/BodyKit Damage Nightmare

    By max_boost in forum Mechanical
    Replies: 14
    Latest Threads: 10-23-2002, 11:37 AM
  5. side markers install

    By mgravel in forum Mechanical
    Replies: 11
    Latest Threads: 08-04-2002, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •