Quantcast
Wastegate issues? - Beyond.ca - Car Forums
Results 1 to 17 of 17

Thread: Wastegate issues?

  1. #1
    Join Date
    Jun 2004
    Location
    Calgary, AB
    My Ride
    1990 Eagle Talon TSI AWD
    Posts
    13
    Rep Power
    0

    Default Wastegate issues?

    help please

    i am gettin some extreme wastegate-like noise from my 90 Talon TSi from about 2800 revs and up

    i briefly checked my ic piping and it seems ok

    could it be the wastegate spring?

    any help/suggestions/donations would be greatly appreciated.

  2. #2
    Join Date
    Sep 2002
    Location
    Calgary
    My Ride
    I dont Drive
    Posts
    721
    Rep Power
    10

    Default

    have you noticed any boost loss?

  3. #3
    Join Date
    Jun 2004
    Location
    Calgary, AB
    My Ride
    1990 Eagle Talon TSI AWD
    Posts
    13
    Rep Power
    0

    Default

    ummmm ALL!!

    i am getting no boost or power absolutely whatever. I am running on a 7.8:1 compression ratio and that is it!

  4. #4
    Join Date
    Dec 2003
    Location
    Calgary
    My Ride
    Jeep
    Posts
    488
    Rep Power
    0

    Default

    Originally posted by 90TSI
    ummmm ALL!!

    i am getting no boost or power absolutely whatever. I am running on a 7.8:1 compression ratio and that is it!
    How close did you check the IC pipes? Call me a Caveman, but if you're getting no boost my immediate guesses in order go like this :

    1) Hose is off or broken
    2) Wastegate is basically wide open almost all the time.

    Do you have a pressure tester to test the pipes? Does you boost gauge even move out of vaccuum?

  5. #5
    Join Date
    Jul 2003
    Location
    Calgary
    My Ride
    Lifted 4.0L H.O.
    Posts
    611
    Rep Power
    9

    Default Wastegate issues?

    Wastegate issues? Try this....Its most likely a vacumn hose.
    Attached Images Attached Images
    Rev high, ride low.

  6. #6
    Join Date
    Nov 2004
    Location
    calgary
    Posts
    103
    Rep Power
    0

    Default

    yea, umm check that shit y0

  7. #7
    Join Date
    Jun 2004
    Location
    Calgary, AB
    My Ride
    1990 Eagle Talon TSI AWD
    Posts
    13
    Rep Power
    0

    Default

    Thanks very much for everyones suggestions and keep em comin.

    For JCX, both intercooler hoses are secured in place and dont seem to be broken. I dont have a pressure tester and my STOCK boost guage (not too reliable) is getting out of vacuum, and im hitting about .5-.7bar on it. The wastegate is what i thought it was. How much do they usually go for?

    For switchblade, which vacuum lines would you be talking about?

    thanks again everyone.

  8. #8
    Join Date
    Jul 2003
    Location
    Calgary
    My Ride
    Lifted 4.0L H.O.
    Posts
    611
    Rep Power
    9

    Default vac line

    Check the black one coming off the wastgate for cracks or leaks.
    Attached Images Attached Images
    Rev high, ride low.

  9. #9
    Join Date
    Jun 2002
    Location
    Calgary
    My Ride
    E36 4dr
    Posts
    655
    Rep Power
    10

    Default

    If your wastegate looks like the one above, check to make sure the leg of the wastegate is actually connected to the wastegate flap on the turbo. (Blah, i don't know terminology)

    Mine came off under boost and resulted in the same scenario as you have right now.

  10. #10
    Join Date
    Feb 2004
    Location
    Calg.
    My Ride
    1ST GEN
    Posts
    387
    Rep Power
    0

    Default

    The thing your talking about is not the wastegate, it is the wategate actuator. The wastegate dumps the excess boost into the exhaust. the actuator regulates this. You would know if you wastegate was malfunctioning. If it was seized, you would build so much boost that your motor would explode. If was wasn't holding, usually caused by the actuator, you wouldn't build any boost (or very little). That could be the problem. Talon actuators are known to go since it is just a rubber diaphram inside and a spring. Because it is 14 years old, it is probably pooched. Change it and see. Dealer charges an arm and a leg for them but if you go to www.machv.com they are much less. I think www.extremepsi.com carries them to. Might be something to look into. Instead of buying one, maybe a friend could lend you one for a try. Make sure the car is cool when you change it, it will make things much easier. Won't be as much like the boardgame "Doctor".

  11. #11
    Join Date
    Feb 2004
    Location
    Calg.
    My Ride
    1ST GEN
    Posts
    387
    Rep Power
    0

    Default

    Revolution Motorsports
    (780) 713-8545


    Ron there can get them in too. Might be easier cause then you don't have to worry about exchange, duty, or brokerage fees. Give him a call for all your DSM needs.

  12. #12
    Join Date
    Nov 2004
    Location
    calgary
    Posts
    103
    Rep Power
    0

    Default

    Originally posted by 2.0turbo

    The wastegate dumps the excess boost into the exhaust.
    no man.

  13. #13
    Join Date
    Feb 2004
    Location
    Calg.
    My Ride
    1ST GEN
    Posts
    387
    Rep Power
    0

    Default

    Originally posted by vegas2005baby


    no man.

    Anyone care to elaberate?

  14. #14
    Join Date
    May 2002
    Location
    a van down by the river
    Posts
    1,871
    Rep Power
    11

    Default

    Originally posted by 2.0turbo



    Anyone care to elaberate?
    wastegate diverts exhaust away from the turbo so it does not make more boost

  15. #15
    Join Date
    Aug 2002
    Location
    Westside - Airdrie, AB
    My Ride
    08 Acura CSX-S Gone:1991 DSM Laser / '96 VW Jetta
    Posts
    130
    Rep Power
    0

    Default

    I'd check out some DSM related sites for your questions....

    www.vfaq.com is a good one
    www.dsmtuners.com has a good tech section and you could probably try searching on thier forums for what you described.

    But yeah I'd check your wastegate actuator and make sure its not seized open.

    If you need a new/used part check out www.calg.dsm.org forums or even on this site. I think some one's parting out thier Talon in the misc. parts section.


    According to www.howstuffworks.com ....

    The Wastegate
    Most automotive turbochargers have a wastegate, which allows the use of a smaller turbocharger to reduce lag while preventing it from spinning too quickly at high engine speeds. The wastegate is a valve that allows the exhaust to bypass the turbine blades. The wastegate senses the boost pressure. If the pressure gets too high, it could be an indicator that the turbine is spinning too quickly, so the wastegate bypasses some of the exhaust around the turbine blades, allowing the blades to slow down.

  16. #16
    Join Date
    Aug 2004
    Location
    kelowna
    Posts
    81
    Rep Power
    0

    Default

    Ive got a wastegate actuator 45$ let me know

  17. #17
    Join Date
    Dec 2002
    Location
    Calgary
    My Ride
    2004 Toyota Echo
    Posts
    432
    Rep Power
    0

    Default

    I can help you see if you have a boost leak. Let me know.
    2004 Toyota Echo

Similar Threads

  1. Wastegate issues?

    By 90TSI in forum Mechanical
    Replies: 2
    Latest Threads: 11-20-2004, 12:05 PM
  2. Re: Wastegate Issues?

    By 90TSI in forum Forced Induction Talk
    Replies: 5
    Latest Threads: 11-07-2004, 03:42 PM
  3. computer issues

    By sexualbanana in forum General
    Replies: 14
    Latest Threads: 04-28-2003, 08:29 AM
  4. Lexus SC300 Issues

    By babyduke in forum Mechanical
    Replies: 4
    Latest Threads: 01-29-2003, 12:48 AM
  5. legal issues with modifications to the bumper bar?

    By 2000impreza in forum Performance Modifications
    Replies: 2
    Latest Threads: 09-10-2002, 12:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •